Picture

We recently discovered two vulnerabilities in TP-Link’s WR841N V8 router that we exploited to obtain custom code execution on the router. After working closely with the vendor to patch the router’s firmware, we are disclosing the details of our work. 

http://blog.senr.io/blog/cve-2017-9466-why-is-my-router-blinking-morse-code#Conclusion